8 задача

ПРОБНИК ФИПИ 10.03.23

слово сойка
под каким номером идет последнее слово которое содержит не более 1 буквы о и не содержит букв с стоящих рядом

s1 = 'сойка'
s = sorted(s1)

k = 0
m = 0

for a1 in s:
    for a2 in s:
        for a3 in s:
            for a4 in s:
                for a5 in s:

                    k = k + 1

                    b = a1 + a2 + a3 + a4 + a5

                    if (a1=='с' and a2=='с') or (a2=='с' and a3=='с') or (a3=='с' and a4=='с') or (a4=='с' and a5=='с'):
                        sod = 1
                    else:
                        sod = 0 

                    if b.count('о')<=1 and sod == 0:
                        m = k
                        sl = b
                        

print(m)
print(sl)

Ответ
2990
соскс

 

Сколько слов длины 4, начинающихся с согласной буквы и заканчивающихся гласной буквой, можно составить из букв М, Е, Т, Р, О? Каждая буква может входить в слово несколько раз. Слова не обязательно должны быть осмысленными словами русского языка.


a = 'метро'
s = 'мтр'
g = 'ео'
k = 0
for a1 in a:
    for a2 in a:
        for a3 in a:
            for a4 in a:
                b = a1 + a2 + a3 + a4
                if a1 in s and a4 in g:
                    print(b)
                    k = k + 1
print(k)

С сайта полякова

(№ 5720) (А. Игнатюк) Алина составляет пятибуквенные слова из букв слова POLYGON, причем известно, что буквы в словах могут повторяться любое количество раз или же не встречаться вовсе. Помогите Алине найти количество различных слов, являющимися палиндромами и содержащими в середине гласную букву.


a = 'polygn'
k = 0
for i in a:
    for j in a:
        k = k + 1
        b = i+j +'o'+j+i
        print(b)
for i in a:
    for j in a:
        k = k + 1
        b = i+j +'y'+j+i
        print(b)
        
print(k)     

Ответ 72

(№ 5719) (А. Игнатюк) Ася составляет семибуквенные слова из букв слова САМОКАТ, причем известно, что буквы в словах могут повторяться любое количество раз или же не встречаться вовсе. Помогите Асе найти количество слов, в котором один раз встречается комбинация САМ, справа и слева от которой находятся одинаковые гласные буквы.


s = 'самокт'
s2 = 'аоа'
k = 0
for a1 in s:
    for a2 in s:
        for a3 in s:
            for a4 in s:
                for a5 in s:
                    for a6 in s:
                        for a7 in s:
                            if a2+a3+a4 == 'сам' and a1 == a5 and a1 in s2:
                                print(a1+a2+a3+a4+a5+a6+a7)
                                k = k + 1
                            if a3+a4+a5 == 'сам' and a2 == a6 and a2 in s2:
                                print(a1+a2+a3+a4+a5+a6+a7)
                                k = k + 1
                            if a4+a5+a6 == 'сам' and a3 == a7 and a3 in s2:
                                print(a1+a2+a3+a4+a5+a6+a7)
                                k = k + 1    
print(k)

Ответ 216