Задача 19

Задача 19

Два игрока, Петя и Ваня, играют в следующую игру. Перед игроками лежит
куча камней. Игроки ходят по очереди, первый ход делает Петя. За один ход
игрок может добавить в кучу один камень или увеличить количество камней
в куче в два раза. Для того чтобы делать ходы, у каждого игрока есть
неограниченное количество камней.
Игра завершается в тот момент, когда количество камней в куче становится
не менее 129. Победителем считается игрок, сделавший последний ход,
т.е. первым получивший кучу из 129 или больше камней.
В начальный момент в куче было S камней, 1 ≤ S ≤ 128.
Будем говорить, что игрок имеет выигрышную стратегию, если он может
выиграть при любых ходах противника.
Укажите такое значение S, при котором Петя не может выиграть за один ход,
но при любом ходе Пети Ваня может выиграть своим первым ходом.


for s in range(0,130):
    #print('Начальная позиция s =', s)
    pwin = 0
    vwin = 0
    for p in 1,2:
        for v in 1,2:
            #print('Начало игры')
            gora = s

            if p == 1:
                gora = gora + 1
            else:
                gora = gora * 2

            if gora >= 129:
                pwin = pwin + 1
            else:
                if v == 1:
                    gora = gora + 1
                else:
                    gora = gora * 2

                if gora >= 129:
                    vwin = vwin + 1
      
    #print('Анализ позиции s =', s)

    if vwin >= 2 and pwin == 0: # вася должен победить хотя бы в пловине случаев (а в половине может сам ошибиться)
        print(s)

Ответ 64