Задача 12

Задача 1

https://inf-ege.sdamgia.ru/problem?id=16890

Исполнитель Редактор получает на вход строку цифр и преобразует её. Редактор может выполнять две команды, в обеих командах v и w обозначают цепочки цифр.

А)  заменить (v, w).

Эта команда заменяет в строке первое слева вхождение цепочки v на цепочку w. Например, выполнение команды

заменить (111, 27)

преобразует строку 05111150 в строку 0527150.

Если в строке нет вхождений цепочки v, то выполнение команды заменить (v, w) не меняет эту строку.

Б)  нашлось (v).

Эта команда проверяет, встречается ли цепочка v в строке исполнителя Редактор. Если она встречается, то команда возвращает логическое значение «истина», в противном случае возвращает значение «ложь». Строка исполнителя при этом не изменяется.

Цикл

ПОКА условие

последовательность команд

КОНЕЦ ПОКА

выполняется, пока условие истинно.

Какая строка получится в результате применения приведённой ниже программы к строке, состоящей из 85 единиц?

НАЧАЛО

ПОКА нашлось (11111)

заменить (111, 2)

заменить (222, 1)

КОНЕЦ ПОКА

КОНЕЦ


a = 85 * '1'
while '11111' in a:
    a = a.replace('111','2',1)
    a = a.replace('222','1',1)
print(a)  

Ответ 211

Задача 2

https://inf-ege.sdamgia.ru/problem?id=26986

Дана программа для Редактора:

НАЧАЛО

ПОКА нашлось (49) ИЛИ нашлось (97) ИЛИ нашлось (47)

    ЕСЛИ нашлось (47)

    ТО заменить (47, 74)

    КОНЕЦ ЕСЛИ

    ЕСЛИ нашлось (97)

    ТО заменить (97, 79)

    КОНЕЦ ЕСЛИ

    ЕСЛИ нашлось (49)

    ТО заменить (49, 94)

    КОНЕЦ ЕСЛИ

КОНЕЦ ПОКА

КОНЕЦ

На вход приведённой ниже программе поступает строка, содержащая 40 цифр 7, 40 цифр 9 и 50 цифр 4, расположенных в произвольном порядке. Запишите без разделителей символы, которые имеют порядковые номера 25, 71 и 105 в получившейся строке.


s = 50 * '4' + 40 * '7' + 40 * '9'
print(s)
while ('49' in s) or ('97' in s) or ('47' in s):
    if '47' in s:
        s = s.replace('47','74',1)
    if '97' in s:
        s = s.replace('97','79',1)
    if '49' in s:
        s = s.replace('49','94',1)
    print(s)    
print(s)
print(s[25] + s[71] + s[104])

Ответ 794

Задача 3

https://inf-ege.sdamgia.ru/problem?id=47216

Дана программа для Редактора:

НАЧАЛО

ПОКА нашлось (>1) ИЛИ нашлось (>2) ИЛИ нашлось (>0)

    ЕСЛИ нашлось (>1)

        ТО заменить (>1, 22>)

    КОНЕЦ ЕСЛИ

    ЕСЛИ нашлось (>2)

        ТО заменить (>2, 2>)

    КОНЕЦ ЕСЛИ

    ЕСЛИ нашлось (>0)

        ТО заменить (>0, 1>)

    КОНЕЦ ЕСЛИ

КОНЕЦ ПОКА

КОНЕЦ

На вход приведённой выше программе поступает строка, начинающаяся с символа «>», а затем содержащая 39 цифр «0», n цифр «1» и 39 цифр «2», расположенных в произвольном порядке.

Определите наименьшее значение n, при котором сумма числовых значений цифр строки, получившейся в результате выполнения программы, является простым числом.


#n = 3
for n in range(0,100):
    s = '>' + 39 * '0' + n * '1' + 39 * '2'
    #print(s)
    while ('>1' in s) or ('>2' in s) or ('>0' in s):
        if '>1' in s:
            s = s.replace('>1','22>',1)
        if '>2' in s:
            s = s.replace('>2','2>',1)
        if '>0' in s:
            s = s.replace('>0','1>',1)
        #print(s)    
    #print(s)

    k = 0
    for i in s:
        if i != '>':
            k = k + int(i)

    ok = 1
    for i in range(2,k):
        if k % i == 0:
            ok = 0
    if ok == 1:
        print(n,'===',k)

Ответ 5