Задача 24 (строки)

Текстовый файл состоит не более чем из 106 символов XY и Z. Определите максимальное количество идущих подряд символов, среди которых каждые два соседних различны.

Для выполнения этого задания следует написать программу. Ниже приведён файл, который необходимо обработать с помощью данного алгоритма.


a = 'xyzxyzzzzyxyzxyzx'
m = 0
k = 1
old = a[0]
for i in a:
    if i != old:
        k = k + 1
    else:
        if k>m:
            m = k
        k = 1
    old = i

# если нужная нам последовательность в самом конце списка, то через елсе мы ее не увидим
if k>m:
    m = k
print(m)  

 

 

Текстовый файл состоит не более чем из 106 символов XY и Z. Определите максимальную длину цепочки вида XYZXYZXYZ… (составленной из фрагментов XYZ, последний фрагмент может быть неполным).

Для выполнения этого задания следует написать программу. Ниже приведён файл, который необходимо обработать с помощью данного алгоритма.


a = 'xyzxyzzzzyxyzxyzxzzzz'
m = 0
k = 1
old = a[0]
for i in a:
    if (i == 'x' and old == 'z') or (i == 'y' and old == 'x') or (i == 'z' and old == 'y'):
        k = k + 1
    else:
        if k>m:
            m = k
        k = 1
    old = i

# если нужная нам последовательность в самом конце списка, то через елсе мы ее не увидим
if k>m:
    m = k
print(m)