Задача 17

В файле содержится последовательность из 10 000 целых положительных чисел. Каждое число не превышает 10 000. Определите и запишите в ответе сначала количество пар элементов последовательности, у которых сумма элементов кратна 60 и хотя бы один элемент из пары делится на 40, затем максимальную из сумм элементов таких пар. В данной задаче под парой подразумевается два различных элемента последовательности. Порядок элементов в паре не важен.

17 — файл


text1 = open("17.txt")
d = []
for i in text1:
    d.append(int(i)) 

k = 0
m = 0
for i in range(len(d)-1):
    for j in range(i+1,len(d)):
        if i != j:
             if ((d[i] + d[j])%60 == 0) and (d[i]%40 == 0 or d[j]%40 == 0):
                k = k + 1
                if (d[i] + d[j]) > m:
                    m = (d[i] + d[j])
        else:
            pass

print(k)
print(m)

ответ

29278
19860